Änderungs-Logbuch Version 7

Die aktuelle Programm-Version ist 7.3.0.3
EvRenesse
Administrator
Administrator
Beiträge: 923
Registriert: 08.02.2005, 10:10
Wohnort: Neuruppin

Änderungs-Logbuch Version 7

Beitragvon EvRenesse » 28.08.2012, 07:41

Version 7.3.0.3 (aktuelle Version)

- Bei der Anzeige der Personenliste (links von der Baumansicht) konnte es unter bestimmten, seltenen Bedingungen dazu kommen, dass eine Person mehrfach aufgeführt wurde. Der Fehler wurde beseitigt.

- Beim Gedcom-Import wurden im Dialog zur Zeichensatz-Auswahl in der Liste mit Wörtern mit diakritischen Zeichen manchmal nur hintere Anteile solcher Wörter aufgeführt. Der Fehler wurde beseitigt.

- Im Dialog Personendaten kann jetzt für jede Person ein Bearbeitungsstand vermerkt werden. Vorab müssen bis zu acht Bearbeitungsstände definiert werden, indem ein beschreibender Text und eine Farbe festgelegt werden. In Baumansichten kann der Bearbeitungsstand als farbige Stecknadel rechts oben an den Personen-Boxen ausgegeben werden. Auf PDF-Karteikarten werden farbige Stecknadeln rechts von den Datensatz-Überschriften ausgegeben; zusätzlich wird der beschreibende Text links im unteren Textabstand ausgegeben, wenn für jede Person eine neue Karteikarte angelegt wird. Für Textverarbeitungs-Vorlagen steht das Daten-Feld <%Bearbeitungsstand%> zur Verfügung. Alle Details stehen im Handbuch in den neuen Abschnitten Die Dialoge > Personendaten bearbeiten > Bearbeitungsstand > Bearbeitungsstände definieren.

- Im Menü Personendaten gibt es zwei neue Funktionen: Liste der Orte erzeugen und Liste der Religionen erzeugen. Diese Listen entsprechen etwa der Liste der Bild- und Dokumentdateien. Sie nennen zu jedem Ort bzw. zu jeder Religion, in welchen Datensätzen sie auftreten.

- In den Baumansichts-Optionen, Registerkarte Box-Inhalt, Liste Ausgabe Personendaten, Bereich spezielle Format-Optionen, kann jetzt mit dem Kontrollfeld Nachnamen von Partner-Eltern in Nachkommenbäumen > um 'verliehene Titel' ergänzen zusätzlich die Ausgabe der verliehenen Titel veranlasst werden.

- Zahlreiche kleinere Korrekturen und Verbesserungen.

Version 7.3.0.2

- Der Stammbaumdrucker speichert die Personendaten in sogenannten Familiendateien mit der Dateierweiterung *.fam. Da andere Genealogieprogramme für ihre ganz anders aufgebauten Datenbanken die gleiche Dateierweiterung nutzen, muss ein Überschreiben solcher Dateien verhindert werden. Der Stammbaumdrucker prüft jetzt vor dem Überschreiben von Dateien *.fam, ob die bereits vorhandene Datei vom Stammbaumdrucker stammt. Wenn nicht, wird das gemeldet und ein Überschreiben verhindert.

- Beim PDF-Export einer Kartei (Menü Personendaten > Datensätze als Kartei in eine PDF-Datei exportieren) kann jetzt zusätzlich das Ausgabedatum im unteren Rand ausgegeben werden. Das Ausgabedatum erleichtert eine Versionskontrolle, wenn man zu einem späteren Zeitpunkt eine neue PDF-Kartei exportiert, davon aber nur einige Karteikarten mit neuen oder geänderten Daten ausdruckt und diese in einen alten Bestand einsortiert.

- In Vorlagen der Textverarbeitung dürfen bei einer Sortierung nach der Struktur des aktuellen Nachkommenbaums bei den einzelnen Datensatznummern keine Verwandten ausgegeben werden: Auftretende Daten-Felder für Vater und Mutter sowie Schleifen für Geschwister, Halbgeschwister, Partner und Kinder werden deshalb jetzt als Syntax-Fehler angesehen. Bei der Sortierung nach der Struktur des aktuellen Nachkommenbaums stehen diese Verwandten in unmittelbarer Nähe, sodass eine zusätzliche Ausgabe nicht erforderlich ist.

- Bei der Erzeugung von Inhaltsverzeichnissen in der Textverarbeitung mit Angabe der Seitennummern erhalten jetzt nicht mehr nur die Seitennummern, sondern auch die Texte der jeweiligen Abschnitts-Überschriften einen Hyperlink auf den Abschnitt im Dokument.

- Bei der Erzeugung von Inhaltsverzeichnissen in der Textverarbeitung mit Einzug für tiefere Ebenen werden die Einzüge jetzt nicht mehr mit Leerzeichen, sondern mit linken Einzügen im Absatzformat realisiert.

- Zahlreiche kleinere Korrekturen und Verbesserungen.

Version 7.3.0.1

- Die Ausgabe von Foto-Platzhaltern für weibliche Personen versagte, weil nicht nach einer Bilddatei FotoPlatzhalterW.jpg gesucht wurde, sondern nach einer Datei FotoPlatzhalterF.jpg (W = weiblich. F = female). Der Fehler wurde beseitigt.

- Wenn beim Gedcom-Import während einer laufenden Konvertierung die Esc-Taste gedrückt wurde oder wenn auf die Schaltfläche Abbrechen geklickt wurde, konnte es unter bestimmten Umständen zu einer endlosen Schleife von Zugriffsverletzungen kommen. In so einem Fall konnte das Programm nur noch über den Taskmanager beendet werden. Der Fehler wurde beseitigt.

- Im Dialog Personendaten, Registerkarte Dokumente, führte die Eingabe, Bearbeitung oder Auswahl des optionalen Titels oder des Gedcom-Typs zu einem Fehler Ungültige Typumwandlung. In der Folge konnten weitere Fehler wie zum Beispiel Zugriffsverletzung... auftreten. Dieser Fehler trat nur in der Version 7.3.0.0 auf. Der Fehler wurde beseitigt.

- Einige kleinere Korrekturen und Verbesserungen.

Version 7.3.0.0

- Bei der Erzeugung von Nachkommennummern der Systeme Henry 2, Henry 4 und Henry 6 wurde die Kind-Nummer je Partnerschaft nicht zurückgesetzt, wenn die Kinder einem unbekannten Vater oder einer unbekannten Mutter folgten. Die Kind-Nummern begannen dann nicht mit 1, sondern bauten auf der Zählfolge der davor liegenden Kind-Gruppe auf. Der Fehler wurde beseitigt.

- Im Menü Personendaten gibt es die Funktion Daten, die nicht in der aktuellen Baumansicht sind, entfernen. Wenn diese Funktion feststellte, dass in den verbleibenden Datensätzen für Taufpaten und/oder Trauzeugen auf Datensätze verwiesen wird, die entfernt werden sollen, erfolgte eine Meldung, die alle betroffenen verbleibenden Datensatznummern nannte. Wenn sehr viele Datensatznummern betroffen waren, konnte das Meldefenster nur einen Ausschnitt zeigen, sodass man weder alle genannten Datensatznummern noch den Meldetext und die Antwort-Schaltflächen sehen konnte. Diese Fälle werden jetzt anders behandelt: Es wird jetzt angeboten, in den betroffenen Datensätzen die Verweise auf zu löschende Taufpaten- oder Trauzeugen-Datensätze zu entfernen oder durch Namen zu ersetzen. Diese Lösung wurde analog auch für die Funktion Daten, die in der aktuellen Baumansicht sind, entfernen realisiert.

- Im Menü Personendaten wurden die Funktionsnamen Daten, die nicht in der aktuellen Baumansicht sind, entfernen und Daten, die in der aktuellen Baumansicht sind, entfernen korrigiert: Statt entfernen heißt es jetzt wie üblich löschen.

- Im Menü Personendaten gibt es jetzt die neue Funktion Datensätze der gleichen Person verschmelzen. Diese Funktion ermöglicht die Zusammenführung von versehentlich erzeugten doppelten Datensätzen einer Person. Die Funktion wird im Handbuch im neuen Abschnitt Datensätze der gleichen Person verschmelzen beschrieben.

- Im Dialog Baumansichts-Optionen, Registerkarte Box-Inhalt, Bereich Ausgabe Vorfahrennummern, gibt es für die Ausgabe von Kekule-Nummern ein neues Kontrollfeld [x] mit Punkten. Hiermit können für eine bessere Lesbarkeit von hinten nach jeweils drei Ziffern Punkte eingefügt werden.

- Im Dialog Person auswählen können in der letzten Spalte der Personenliste verschiedene Personendaten gezeigt werden. Wenn dort Orte gezeigt werden und wenn dort Ortsangaben mit mehreren kommagetrennten Ortsebenen vorkommen, kann jetzt auch nach höheren Ortsebenen sortiert werden. In diesen Fällen wird nach einem Klick auf den Spaltenkopf in einer Meldung gefragt, nach welcher Ortsebene sortiert werden soll. Die gewählte Ortsebene wird im Spaltenkopf ausgegeben.

- Im Dialog Verwandtschaftsbaum erzeugen gibt es jetzt im 3. Schritt eine neue Schaltfläche Liste kopieren. Hiermit kann der Inhalt der Liste der ermittelten Nachkommenbäume in die Windows-Zwischenablage kopiert werden, um sie in einer Textverarbeitung oder in einem Editor einzufügen und weiter zu nutzen. Mit so einer Liste kann extern dokumentiert werden, welche Nachkommenbäume ermittelt wurden und welche für die Ausgabe eingeschaltet oder ausgeschaltet wurden; intern wird die Liste wie bisher in einer Baumansichtsdatei *.sad des erzeugten Verwandtschaftsbaums gespeichert.

- In der Textverarbeitung gibt es ein neues Befehls-Feld [WennVorfNachkNrDa >] (Bedingte Ausführung: Wenn für die laufende Datensatznummer eine Vorfahren- oder Nachkommennummer vorhanden ist). Dieses Befehls-Feld eignet sich zum Beispiel für die Verwendung mit den im folgenden Abschnitt beschriebenen neuen Daten-Feldern.

- In der Textverarbeitung gibt es neue Daten-Felder für weitere Personendaten von Partnern: PartnerGeburtsort, PartnerTaufort, PartnerReligion, PartnerSterbeort, PartnerTodesursache, PartnerVerhWortGefOrt, PartnerBestattungsort, PartnerBeruf und PartnerBerufZeile1. Diese Daten-Felder ermöglichen zusammen mit dem neuen Befehls-Feld [WennVorfNachkNrDa >] die Erzeugung von Listen, in denen Personen ohne Nachkommennummer keinen eigenen Abschnitt erhalten, in denen aber einige Daten dieser Personen in denjenigen Abschnitten aufgeführt werden, in denen sie als Partner genannt werden.

- Einige kleinere Korrekturen und Verbesserungen.

Version 7.2.0.3

- In der Vorlagen-Fibel der Version "7.2.0.2 Mai 2015" war in mehreren Vorlagen-Beispielen ein Fehler, der bei der Syntax-Prüfung erkannt wurde. Der Fehler wurde beseitigt.

- Die Nachkommennummern der Systeme Henry 1, Henry 3 und Henry 5 enthielten einen Fehler in der Zählung von Kindern, die aus mehreren Partnerschaften stammen: Die Kinder wurden je Partnerschaft ab 1 gezählt, müssen in diesen Systemen aber über alle Partnerschaften ab 1 gezählt werden. Der Fehler wurde beseitigt.

- Die Sortierung von PDF-Karteikarten, PDF-Lesezeichen und erfassten Datensatznummern in Vorlagen der Textverarbeitung nach Nachkommennummern der Systeme Henry 2, Henry 4 und Henry 6 berücksichtigte nicht die in diesen Systemen verwendeten Partnerschaftsbuchstaben. Der Fehler wurde beseitigt.

- In der Version 7.2.0.2 versagten bei der Übersetzung von Textverarbeitungs-Vorlagen die Daten-Felder für Vorfahren-/Nachkommen-Nummern von Verwandten der laufenden Datensatznummer, also zum Beispiel <%PartnerVorfNachkNr%>, <%KindVorfNachkNr%> oder <%VaterVorfNachkNr%>. Der Fehler wurde beseitigt.

- In den Baumansichts-Optionen, Registerkarte Box-Inhalt, Liste Ausgabe Personendaten, Abschnitt Multimedia, kann jetzt eingestellt werden, dass in den Personen-Boxen bei fehlender Zuordnung eines Fotos ein Foto-Platzhalter ausgegeben wird. Das Programm stellt einfache Foto-Platzhalter-Dateien zur Verfügung. Wie man diese durch eigene Foto-Platzhalter ersetzen kann, steht im Handbuch im Abschnitt Baumansichts-Optionen, Registerkarte Box-Inhalt.

- In der Textverarbeitung gibt es im Menü Format die neue Funktion Text-Bausteine ohne Formatvorlagen suchen. Diese Funktion hilft, die vollständige Verwendung von Formatvorlagen sicherzustellen. Nur bei vollständiger Verwendung von Formatvorlagen kann die Formatierung größerer Dokumente später leicht geändert werden.

- Einige kleinere Korrekturen und Verbesserungen.

Version 7.2.0.2

- In der Version 7.1.0.4 wurde eine interne technische Änderung eingeführt, die eine damals nicht erkannte negative Auswirkung hat. Dabei geht es um die Konfigurationsdaten von Verwandtschaftsbäumen, die im Dialog Verwandtschaftsbaum erzeugen eingestellt werden. Im Folgenden werden zwei Szenarien geschildert, die den Fehler hervorbrachten (weitere waren möglich):
    - Bei angezeigtem Verwandtschaftsbaum und Öffnung des Dialogs Verwandtschaftsbaum erzeugen und anschließendem sofortigen Abbrechen führte ein erneutes Öffnen dieses Dialogs zum Absturz des Programms, sodass man den Task-Manager bemühen musste.
    - Wenn als aktuelle Baumansicht ein Verwandtschaftsbaum angezeigt wurde und in der Textverarbeitung eine Vorlage mit Auto-Baumansichten übersetzt wurde, gab es einen Fehler, der zumindest die Übersetzung abbrach, der aber auch zum Absturz des Programms führen konnte.
Der Fehler wurde beseitigt.

- Mit Version 7.2.0.1 wurde die Verwendung von freien Bild-Objekten mit Baumansichtsdateien (*.sad) in Verwandtschaftsbäumen unterbunden. Nach Beseitigung des im vorigen Abschnitt beschriebenen Fehlers wurde diese Einschränkung wieder aufgehoben.

- Wenn man nach der Erzeugung von Teil-Bäumen mit dem Teil-Baum-Assistenten auf der letzten Tafel die Funktion Alle Teil-Bäume exportieren wählte, scheiterte der Export, wenn die Registerkarte mit dem ursprünglichen Gesamt-Baum angezeigt wurde. Der Fehler wurde beseitigt.

- In Teil-Baum-Projekten werden jetzt im Gesamt-Baum zugeordnete Ersatz-Farbschemata für die Teil-Bäume übernommen.

- Die Verwendung von Vorfahren-/Nachkommennummern von Personen, die wegen Implex/Ahnenschwund mehrere solche Nummern führen, wurde überarbeitet:
    - Bei Ausgabe von Vorfahren-/Nachkommennummern in der Überschrift von PDF-Karteikarten von Personen, die in der aktuellen Baumansicht oder im Gesamt-Baum eines Teil-Baum-Projekts mehrfach auftreten, werden jetzt alle Vorfahren-/Nachkommennummern in der Überschrift der Karteikarte genannt.
    - In den PDF-Optionen, Bereich Kartei, neuer Unterbereich Kartei-Lesezeichen, sortiert nach Vorfahren- oder Nachkommennummern, gibt es ein neues Kontrollfeld Bei ALLEN Duplikats-Lesezeichen ALLE Nummern ausgeben. Wenn dieses Kontrollfeld markiert wird, wird jedes Lesezeichen für Karteikarten von Personen, die in der aktuellen Baumansicht oder im Gesamt-Baum eines Teil-Baum-Projekts mehrfach auftreten, zusätzlich die Vorfahren-/Nachkommennummern der weiteren Vorkommen nennen. Diese PDF-Lesezeichen führen alle zur gleichen Karteikarte.
    - Nach Vorfahren-/Nachkommennummern sortierte PDF-Lesezeichen für Duplikats-Boxen in einer Baumansicht werden je Duplikats-Box einzeln angelegt und nennen nur eine einzige Vorfahren-/Nachkommennummer. Die PDF-Lesezeichen führen zur jeweiligen Duplikats-Box. Die Duplikats-Querverweise in den Duplikats-Boxen führen zu den anderen Duplikats-Boxen.
    - Nach Vorfahren-/Nachkommennummern sortierte PDF-Lesezeichen für Boxen in den Teil-Bäumen eines Teil-Baum-Projekts werden je Box einzeln angelegt und nennen nur eine einzige Vorfahren-/Nachkommennummer. Handelt es sich um die Box einer Person, die in mehreren Teil-Bäumen auftritt, enthält das PDF-Lesezeichen zusätzliche untergeordnete PDF-Lesezeichen. Die PDF-Lesezeichen führen zum Teil-Baum mit der jeweiligen Box. Die Querverweise in den Boxen führen zu den anderen Teil-Bäumen mit den anderen Boxen.
    - In Teil-Baum-Projekten wurde die Vorfahren-/Nachkommennummern-Ausgabe für Boxen von Personen, die in mehreren Teil-Bäuemmn auftreten, so geändert, dass die Nummern nur noch entsprechend der Struktur-Position im Gesamt-Baum ausgegeben werden. Bisher wurde in solchen Boxen die Vorfahren-/Nachkommennummer ausgegeben, die zu der Box gehört, die im Gesamt-Baum zuerst auftritt.
    - Wenn beim Erzeugen eines Vorfahrenbaums mit aktivierten Kekule-Vorfahrennummern oder eines Nachkommenbaums mit aktivierten Henry- oder Aboville-Nachkommennummern die neue Ausgangsperson in der bisherigen Baumansicht mit Duplikaten auftritt, werden bei der Nummern-Startwert-Auswahl für die neue Baumansicht jetzt bis zu drei der bisherigen Nummern der Duplikate angeboten. Bisher wurde trotz vorhandener Duplikate nur eine einzige Nummer angeboten.
- Wenn Nachkommennummern der Systeme Gotha 1 oder Gotha 2 verwendet werden, ist keine Sortierung von PDF-Karteikarten, PDF-Lesezeichen oder erfassten Datensatznummern in Vorlagen der Textverarbeitung nach diesen Nachkommennummern möglich. Die Gotha-Systeme sind für eine Sortierung ungeeignet und vergeben auch keine Nummer für die Ausgangsperson.

- In der Textverarbeitung liefert das Daten-Feld <%VorfNachkNr%> nun alle Vorfahren- oder Nachkommennummern zu einer Datensatznummer. Bei Vorliegen von Implex/Ahnenschwund und bei Sortierung der erfassten Datensätze nach Vorfahren- oder Nachkommennummern können Personen mehrere Vorfahren- oder Nachkommennummern haben, die jetzt durch <%VorfNachkNr%> alle mit einem Plus-Zeichen getrennt ausgegeben werden. Wenn dies nicht gewünscht wird, kann das neue Daten-Feld <%NurEineVorfNachkNr%> verwendet werden, das nur die erste Vorfahren- oder Nachkommennummern ausgibt.

- In der Textverarbeitung gibt es für Vorlagen ein neues Befehls-Feld [WennDsNrErstesVorkommen >] sowie zwei neue Daten-Felder <%ZuerstAufgetrVorfNachkNr%> und <%WeitereVorfNachkNr%>. Diese Felder ermöglichen die Ausgabe von besseren Vorfahrenlisten, sortiert nach Vorfahrennummern, und Nachkommenlisten, sortiert nach Nachkommennummern. Details stehen in den Referenz-Abschnitten des Handbuchs und der Vorlagen-Fibel. Außerdem gibt es in der Vorlagen-Fibel ein komplettes Vorlagen-Beispiel Vorfahrenlisten, sortiert nach Vorfahrennummern zum Kopieren.

- In der Textverarbeitung gibt es vier neue Daten-Felder für die Adressen-Sortierdaten aus den Personendaten, Registerkarte Kontakt: <%Ort%>, <%Land/Kanton%>, <%Postleitzahl%> und <%Staat%>. In den Vorlagen-Beispielen wurde die Kontakt-Ausgabe entsprechend ergänzt.

- Beim Gedcom-Export wird jetzt nach dem Speichern der Gedcom-Datei angeboten, von den zugeordneten Foto- und Dokumentdateien eine einfache Liste der Dateinamen in einer Textdatei oder Kopien der Dateien in einer ZIP-Datei zu speichern. Das Angebot erscheint automatisch in einem Dialog, wenn Foto- oder Dokumentdateien zugeordnet sind.

- Das Programm startet jetzt mit einem Startbild (Splash Screen), damit bei einer längeren Startphase kein Zweifel aufkommt, ob das Programm überhaupt startet.

- Einige kleinere Korrekturen und Verbesserungen.

Version 7.2.0.1

- Mit Veröffentlichung dieser Version beginnt parallel die Veröffentlichung von Videos mit Anleitungen zu bestimmten Themen. Die Videos sind über die Homepage des Stammbaumdruckers http://www.stammbaumdrucker.de zu erreichen. Außerdem kann man im Menü Hilfe/Info die neue Funktion Web Stammbaumdrucker-Videos nutzen.

- In der Textverarbeitung konnte bei der Übersetzung einer Vorlage für eine strukturierte Nachkommenliste ein Fehler Zugriffsverletzung... auftreten, wenn eines der Daten-Felder <%NKPartnerEltern%>, <%NKPartnerHeiratsdaten%> oder <%NKPartnerHeiratsUndScheidungsdaten%> verwendet wurde und wenn in der aktuellen Baumansicht statt eines rechts angeordneten Partners nur eine Box unbekannter Vater oder unbekannte Mutter vorhanden war. Der Fehler wurde beseitigt.

- Wenn in Verwandtschaftsbäumen ein freies Bild-Objekt mit einer Baumansichtsdatei (*.sad) ausgegeben wurde, konnte ein Fehler Zugriffsverletzung... auftreten. Die Ausgabe von freien Bild-Objekten mit Baumansichtsdateien wird jetzt in Verwandtschaftsbäumen unterbunden. Da Verwandtschaftsbäume im Normalfall sowieso alle Verwandten zeigen, ist in ihnen die zusätzliche Ausgabe weiterer Strukturen eigentlich unnötig; wenn es dennoch gewünscht wird, können Baumansichten als erweiterte Metadateien (*.emf) exportiert und in Bild-Objekten verwendet werden.

- Die zuletzt verwendeten Einstellungen für freie Text-Objekte, freie Bild-Objekte, freie Geo-Objekte, Spalten- und Zeilen-Nummern, Personen-Verzeichnisse und Duplikats-Verbinder wurden unter bestimmten Bedingungen nicht als Voreinstellungen gespeichert. Der Fehler wurde beseitigt.

- Seit der Version 7.1.0.4 war die Ermittlung von Nachkommennummern, Vorfahrennummern und Ident-Codes bei der Erzeugung einer PDF-Kartei und bei der Vorlagen-Übersetzung in der Textverarbeitung bei der Sortierung nach diesen Werten gestört. Dadurch konnte nicht nach diesen Werten sortiert werden, dadurch wurden diese Werte nicht ausgegeben, und dadurch fehlten die PDF-Lesezeichen für diese Werte. Der Fehler wurde beseitigt.

- Wenn für den Hintergrund freier Text-Objekte ein Bild gewählt wurde (z. B. ein Farbverlauf), wurde im Editor für Text-Objekte ein weißer Hintergrund verwendet, weil der Editor keine Hintergrund-Bilder ausgeben kann. Damit war im Editor eine helle Schrift nicht mehr erkennbar. Jetzt wird im Editor stets die gewählte Hintergrund-Farbe verwendet, auch wenn für das Text-Objekt ein Hintergrund-Bild gewählt wurde. Damit ist im Editor auch helle Schrift sichtbar, wenn man zuvor eine dunkle Hintergrund-Farbe eingestellt hat.

- Fehlermeldungen in der Syntax-Prüfung von Vorlagen der Textverarbeitung, die Optionen der aktuellen Baumansicht betreffen, enthalten jetzt einen Hinweis auf die betroffene Baumansichts-Option.

- Einige kleinere Korrekturen und Verbesserungen.

Version 7.2.0.0

- In der Version 7.1.0.4 konnte es beim Laden einer Teil-Baum-Projekt-Datei zu einer Meldung LetztePanelNr = x kommen. Diese Meldung wurde zu Testzwecken eingebaut und versehentlich vor der Veröffentlichung nicht wieder entfernt. Der Fehler wurde beseitigt.

- Beim Einfügen eines Fotos in eine Box der aktuell gezeigten Baumansicht mit Drag&Drop wurde der Änderungszustand nicht erfasst und damit blieb die Speichern-Funktion deaktiviert. Der Fehler wurde beseitigt.

- Beim Laden eines Teil-Baum-Projektes konnte bei sichtbarer Personenliste (Liste links von der Baumansicht) ein Fehler Zugriffsverletzung... auftreten. Der Fehler wurde beseitigt.

- Jetzt kann für freie Text-Objekte, freie Geo-Objekte (Ausnahme: Geschlossene Kurven) und Personen-Verzeichnisse anstatt einer Hintergrund-Farbe alternativ auch ein Hintergrund-Bild gewählt werden. Das war bisher nur für die gesamte Grafik und Personen-Boxen möglich. Damit können nun die meisten Objekte lebendiger gestaltet werden. Als Hintergrund-Bilder können auch die neuen sogenannten Farbverläufe verwendet werden (siehe nächsten Punkt).

- Wichtige Neuheit: Mit den neuen Farbverläufen wird eine neue Gestaltungsmöglichkeit eingeführt. Farbverläufe sind spezielle JPEG-Dateien, die einen Farbverlauf enthalten. Sie eignen sich als Hintergrund-Bilder für die meisten Objekte. Im Ordner Beispielbilder im Haupt-Verzeichnis für Bilddateien (siehe Programm-Optionen, Registerkarte Verzeichnisse) werden einige Farbverläufe bereitgestellt. Daneben kann der Anwender mit Hilfe des neuen Farbverlaufs-Editors selbst Farbverläufe nach seinen eigenen Vorstellungen erzeugen und als Hintergrund-Bilder einsetzen. Der neue Farbverlaufs-Editor kann im Menü Extras aufgerufen werden. Er wird im Handbuch in dem neuen Abschnitt Der Farbverlaufs-Editor beschrieben.

- In den Baumansichts-Optionen, Registerkarte Profile, wurden zwei Beispiel-Profile mit Farbverläufen zugefügt: Grafik- und Box-Hintergrund mit hellen oder dunklen Farbverläufen.

- Hintergrund-Bilder von Personen-Boxen sind jetzt auch mit Rundungen der Box-Ecken vereinbar. Die Bildbereiche unter den Rundungen werden nicht ausgegeben.

- Achtung: Ältere Programm-Versionen vor 7.2.0.0 können Baumansichtsdateien *.sad, die von Programm-Versionen ab 7.2.0.0 gespeichert wurden, nicht lesen. Umgekehrt gibt es selbstverständlich kein Problem: Ältere Baumansichtsdateien können stets von neueren Programm-Versionen gelesen werden.

- Im umgebungsabhängigen Menü von Boxen rechts angeordneter Partner in Nachkommenbäumen gibt es die neue Funktion Partner-Box möglichst weit nach links verschieben. Mit dieser Funktion kann man Partner-Boxen nach links näher zur Ausgangsperson oder zum Nachkommen verschieben. Normalerweise werden Partner zentriert über ihren Kindern dargestellt. Ab dem zweiten Partner kann die Spreizung der Struktur durch eine größere Anzahl Kinder und weiterer Nachkommen dazu führen, dass der Partner weit entfernt von der Ausgangsperson oder vom Nachkommen angeordnet wird. Mit dieser Funktion kann er näher an die Ausgangsperson oder den Nachkommen heranrücken, allerdings mit dem Nachteil, dass er nicht mehr zentriert über seinen Kindern steht.

- Beim Ausdruck einer Baumansicht auf mehreren Blättern wurde die optionale Ausgabe von Blattnummern und Anschlussblattnummern geändert. Jetzt gilt: Wenn mehrere Blätter quer und/oder hoch eingestellt wurden und wenn die Druck-Überlappung mindestens 8 mm beträgt und wenn die Ausgabe von Schnittlinien aktiviert wurde, werden an den überlappten Rändern auf dem unteren Blatt die Blattnummern sowie die jeweiligen Anschlussblattnummern in der Schnittlinien-Farbe ausgedruckt.

- Bei der Erzeugung von Spalten-/Zeilen-Nummern wurde die Positionierung der äußeren freien Text-Objekte optimiert. Deren Lage hängt jetzt auch von den Einstellungen für Grafik-Hintergrund-Bilder in den Baumansichts-Optionen, Registerkarte Grafik-Inhalt, und deren tatsächlicher Lage ab: Wenn die Grafik-Hintergrund-Bilder als Symbol ausgegeben werden und wenn die Option Auch unter den Grafik-Rändern nicht aktiviert ist, wird ein eventueller Überstand der Grafik-Hintergrund-Bilder über den äußeren Boxen-Rand so berücksichtigt, dass die freien Text-Objekte nicht auf dem Rand der Grafik-Hintergrund-Bilder liegen.

- In den Kartei-Export-Optionen für den Export der PDF-Kartei gibt es zwei neue Kontrollfelder: Liste der Fotodateinamen und Fotodateinamen mit Pfad. Mit dem ersten Kontrollfeld kann für jeden Datensatz am Ende der jeweiligen Karteikarte die Ausgabe einer Liste der Namen der zugeordneten Fotodateien aktiviert werden. Mit dem zweiten Kontrollfeld wird festgelegt, ob nur die Dateinamen oder die Dateinamen mit den kompletten Pfaden ausgegeben werden.

- In der Textverarbeitung gibt es im Menü Ansicht die neue Funktion Gehe zur Seite.... Damit kann direkt zu einer Seitennummer gesprungen werden.

- In der Textverarbeitung gibt es ein neues Daten-Felder <%NKPartnerHeiratsUndScheidungsdaten%> für strukturierte Personenlisten in der Sortierung eines Nachkommenbaums.

- Wichtige Neuheit: In den Gedcom-Optionen, Registerkarte Profile, wurde ein neues festes Profil [ Gedcom 5.5.1 "Gedcom-L" ] zugefügt. Mit diesem Profil kann man die Gedcom-Optionen mit zwei Mausklicks so einstellen, dass sie den Vereinbarungen deutschsprachiger Programmautoren entsprechen, die unter Moderation des Vereins für Computergenealogie e. V. in dessen Mailingliste "Gedcom-L" getroffen wurden.

- Beim Gedcom-Import werden jetzt nicht mehr nur zwei, sondern zahlreiche NAME-Tags gelesen. Der erste NAME-Tag wird stets als Geburtsname gelesen, die folgenden NAME-Tags werden abhängig vom untergeordneten TYPE-Tag interpretiert: Ein TYPE-Tag-Wert married kennzeichnet einen Ehenamen. Ein TYPE-Tag-Wert aka kennzeichnet einen weiteren Namen, der optional mit dem Zusatz Auch bekannt als... in die Notiz geschrieben werden kann. Ein TYPE-Tag-Wert variant kennzeichnet Namen-Varianten, die optional den Namen in Klammern zugefügt werden können, getrennt für Vornamen und Nachname. Ein TYPE-Tag-Wert called kennzeichnet einen zusätzlichen Namen, der optional als Kosename übernommen werden kann. Ein TYPE-Tag-Wert birth kennzeichnet einen Geburtsnamen; dieser Geburtsname überschreibt den Geburtsnamen aus dem ersten NAME-Tag. Die entsprechenden Optionen werden in den Gedcom-Optionen, Registerkarte Import-Optionen, in der Liste Behandlung spezieller Gedcom-Tags und -Daten ausgewählt.

- In den Gedcom-Optionen, Registerkarte Export-Optionen, wurden weitere Ziel-Tags für den Export des Status der Partnerschaft eingeführt.

- In den Gedcom-Optionen, Registerkarte Ehenamen-Codierung, wurde eine neue Methode Typisierter NAME-Tag zugefügt. Bei dieser Methode folgt einem NAME-Tag mit dem Ehenamen ein untergeordneter TYPE-Tag mit dem Wert married.

- In den Gedcom-Optionen, Registerkarte Heiratsdaten-Codierung, sind die Optionsfelder für die Auswahl einer Methode beim Import entfallen. Jetzt werden stets alle drei Methoden beim Import verwendet. Dabei werden auch doppelte Heiratsdaten aus verschiedenen Methoden gelesen, zum Beispiel die standesamtlichen Heiratsdaten aus einem Benutzerdefinierten Tag und die kirchlichen Heiratsdaten aus einem Benutzerdefinierten Merkmal.

- In den Gedcom-Optionen, Registerkarte Bürgerort-Codierung, wurde nur für den Import die Methode Benutzerdefiniertes Merkmal mit untergeordnetem PLAC-Tag so erweitert, dass statt des EVEN-Tags auch ein FACT-Tag akzeptiert wird.

- In den Gedcom-Optionen, Registerkarte Taufpaten-Codierung, wurde für die Methode Benutzerdefiniertes Tauf-Merkmal mit Referenz auf Taufpaten für den Tag der dritten Ebene ein Eingabefeld eingefügt. In diesem Eingabefeld steht normalerweise TYPE; dieser Tag kann jetzt bei Bedarf in RELA geändert werden.

- In den Gedcom-Optionen, Registerkarte Trauzeugen-Codierung, wurde für die Methode Benutzerdefinierter ASSO-Tag mit Referenz auf Trauzeugen für den ASSO-Tag ein Eingabefeld eingefügt. In diesem Eingabefeld steht normalerweise ASSO; dieser Tag kann jetzt bei Bedarf in _ASSO geändert werden.

- Einige kleinere Korrekturen und Verbesserungen.

Version 7.1.0.4

- Ab dieser Version läuft der Stammbaumdrucker nicht mehr unter Windows XP. Es wird jetzt mindestens Windows Vista vorausgesetzt. Die letzte unter Windows XP laufende Version 7.1.0.3 wird auf der Homepage weiterhin zum Herunterladen angeboten. Damit können Anwender, die sich von Windows XP nicht trennen wollen oder können, das Setup bei Bedarf für eine Neuinstallation herunterladen.

- Ab Version 7.1.0.3 gibt es im Dialog Person auswählen ein neues Kontrollfeld Nur Geburtsnamen. Wenn dieses Kontrollfeld markiert ist, wird statt der zwei Spalten aktueller/letzter Nachname und abweichender Geburtsname nur eine Spalte Geburtsname gezeigt. Für diese Konstellation funktionierte die Schnell-Suche nicht. Der Fehler wurde beseitigt.

- Die Übersetzung einer Textverarbeitungs-Vorlage brach ab, wenn in den Datensätzen in einem Berufs-, Notiz- oder Quellen/i]-Datenfeld nur ein Zeilenumbruch, aber kein Text enthalten war. Der Fehler wurde beseitigt.

- Bei der Übersetzung einer [i]Textverarbeitungs-Vorlage
konnte es zu unerwarteten Abbrüchen ohne eine passende Fehlermeldung kommen. Dies konnte bei einer großen Anzahl von Personendatenblättern mit eingebetteten Bilddateien und/oder Auto-Baumansichten passieren. Es handelte sich um eine Überlastung der Windows-Grafik-Ressourcen. Das Programm prüft jetzt die Belastung der Windows-Grafik-Ressourcen und bricht den auslösenden Vorgang rechtzeitig mit einer entsprechenden Meldung ab, ohne dass es zu einem Programm-Absturz kommt. Außerdem wurden im Textverarbeitungs-Menü Extras zwei neue Funktionen aufgenommen: Belastung der Windows-Grafik-Ressourcen anzeigen und Grenze für Windows-Grafik-Ressourcen ändern. Im Handbuch gibt es dazu den neuen Abschnitt Die Textverarbeitung > Verwendung von Vorlagen > Befehls-Feld-Referenz > Wiederholte Ausführung in Schleifen > Belastung der Windows-Grafik-Ressourcen.

- In der Textverarbeitung enthielten die Daten-Felder <%MuttterGeburtsdatum%>, <%MuttterTaufdatum%>, <%MuttterSterbedatum%> und <%MuttterBestattungsdatum%> einen Schreibfehler: Mutter wurde versehentlich mit 3 t geschrieben. Die Erkennung dieser Daten-Felder beim Übersetzen funktionierte nur mit dem Schreibfehler; eine Korrektur durfte daher nicht erfolgen. Der Fehler wurde jetzt beseitigt. Beim Öffnen einer alten Vorlage, die solche Schreibfehler enthält, wird darauf hingewiesen, dass diese zu korrigieren sind.

- Im Dialog Personendaten, Registerkarten Fotos und Dokumente, werden jetzt in einem Hinweisfenster die vollständigen Dateinamen einschließlich Pfad angezeigt, wenn die Maus auf einen Dateinamen zeigt.

- Die Ausgabe von Partner-Eltern in Nachkommenbäumen wurde erweitert: Jetzt können auch der Beruf (vorn oder hinten), aus dem Hause sowie Besitzung ausgegeben werden. Als Beruf wird nur die erste Zeile des mehrzeiligen Datenfeldes Beruf ausgegeben. Die Einstellung erfolgt in den Baumansichts-Optionen, Registerkarte Box-Inhalt, Liste Ausgabe Personendaten, Abschnitt Spezielle Format-Optionen, unter Nachnamen von Partner-Eltern in NK.-B.. Der so konfigurierte Text für die Ausgabe der Partner-Eltern in Personen-Boxen wird auch in der Textverarbeitung zur Übersetzung des dortigen Daten-Feldes <%NKPartnerEltern%> verwendet.

- In der Textverarbeitung gibt es neue Daten-Felder <%NKPartnerHeiratsdaten%> und <%BerufZeile1%> für optimale strukturierte Personenlisten in der Sortierung eines Nachkommenbaums.

- Die Übersetzung einer Textverarbeitungs-Vorlage mit einer strukturierten Personenliste in der Sortierung eines Nachkommenbaums wurde optimiert, sodass das Erscheinungsbild besser dem der üblichen genealogischen Handbüchern entspricht.

- Bei der Übersetzung einer Textverarbeitungs-Vorlage mit Auto-Baumansichten können jetzt die Daten-Felder <%AutoBaumansichtXXX%> mit Befehls-Feldern für eine bedingte Ausführung eingefasst werden. Damit kann für Personen ohne jedes Verwandtschaftsverhältnis die Ausgabe einer Auto-Baumansicht verhindert werden, die nur aus einer einzigen Personen-Box bestehen würde.

- In der Textverarbeitung wurde der PDF-Export überarbeitet. Der Seitenumbruch im exportierten PDF-Dokument entspricht jetzt exakt dem in der Textverarbeitung.

- Einige kleinere Korrekturen und Verbesserungen.

Version 7.1.0.3

- In den Personen-Boxen kann die Lebensspanne in der besonders kompakten Form "JJJJ - JJJJ" ausgegeben werden, wenn eine Reihe von Bedingungen erfüllt ist. Diese Bedingungen sind im Handbuch im Abschnitt Die Dialoge, Baumansichts-Optionen, Registerkarte Box-Inhalt, in dem Absatz Eine besonders kompakte Form der Datumsausgabe kann... aufgeführt. Bei nicht auswertbaren oder falschen Datumsangaben in Klammern (sogenannten Textphrasen) versagte die kompakte Ausgabe der Lebensspanne. Unter den Bedingungen fehlte der Ausschluss von Textphrasen. Der Fehler wurde beseitigt.

- Im Dialog Personendaten bearbeiten wurde an die Eintragungen in mehrzeiligen Eingabefeldern (Beruf, Notiz, Quellen) jedes Mal eine Leerzeile angehängt, wenn der Datensatz mit der Funktion DS übernehmen übernommen wurde. Dies wirkte sich nur bei Ausgaben über Daten-Felder in Vorlagen der Textverarbeitung negativ aus. Der Fehler wurde beseitigt.

- Bei der Erzeugung von Verwandtschaftsbäumen konnte es zu einer unnötigen zweiten Darstellung eines Elternpaares kommen, wenn für beide Eltern keine Eltern gespeichert waren und wenn für beide Eltern nur eine einzige Partnerschaft gespeichert war und wenn in der ersten Darstellung des Elternpaares die Mutter links angeordnet war und der Vater rechts. Dies konnte zum Beispiel auftreten, wenn die Mutter eines solchen Elternpaares als Ausgangsperson des Verwandtschaftsbaums festgelegt wurde. Der Fehler wurde beseitigt.

- Beim Export einer Baumansicht in eine PDF- oder Grafik-Datei wurde bisher stets ein automatisch erzeugter Dateiname voreingestellt. Falls die Baumansicht bereits in einer Baumansichtsdatei (*.sad) gespeichert wurde, wird jetzt der Dateiname dieser Baumansichtsdatei für den Export voreingestellt. Dies vereinfacht den Export in den Fällen, in denen für die Baumansichtsdateien keine automatisch erzeugten, sondern benutzerdefinierte Dateinamen verwendet wurden (Menü Datei, Baumansichtsdatei speichern unter...).

- Im Menü Personendaten gibt es die neue Funktion Datensätze, die in der aktuellen Baumansicht sind, entfernen. Diese Funktion ist das Gegenstück zur vorhandene Funktion Datensätze, bis auf die in der Baumansicht, entfernen, die nun umbenannt wurde in Datensätze, die nicht in der aktuellen Baumansicht sind, entfernen.

- Im Dialog Person auswählen gibt es ein neues Kontrollfeld Nur Geburtsnamen. Wenn dieses Kontrollfeld markiert ist, wird statt der zwei Spalten aktueller/letzter Nachname und abweichender Geburtsname nur eine Spalte Geburtsname gezeigt. Bei Personen, für die kein abweichender Geburtsname gespeichert ist, wird in dieser Darstellung der aktuelle/letzte Nachname als Geburtsname verwendet.

- Das umgebungsabhängige Menü der optionalen Personenliste (links neben der Baumansicht) enthält jetzt eine Funktion Personenliste kopieren. Damit kann die Liste in die Windows-Zwischenablage kopiert und von dort in einen Editor oder eine Textverarbeitung zum Bearbeiten und/oder Drucken eingefügt werden.

- Beim Beenden des Programms oder beim Schließen der Familiendatei führten geänderte Verlaufswerte zu einer Rückfrage, ob die Familiendatei gespeichert werden soll. Verlaufswerte sind 1. die zuletzt verwendete Baumansichtsdatei (*.sad), 2. die zuletzt verwendeten Baumansichts-Optionen, 3. die zuletzt verwendete Baum-Art, 4. die 8 zuletzt verwendeten Ausgangspersonen sowie 5. die 16 zuletzt in einer Baumansicht gesuchten Personen. Die Speichern-Rückfrage erfolgte auch, wenn die eigentlichen Personendaten, das Impressum sowie die Notizen zur Familiendatei nicht geändert wurden. Solche Speichern-Rückfragen konnten verwirrend sein. Sie erfolgen jetzt nur noch, wenn eine Änderung der eigentlichen Personendaten, des Impressums oder der Notizen zur Familiendatei vorliegt. Geänderte Verlaufswerte werden nun ohne Rückfrage automatisch gespeichert.

- Die Integritätsprüfung wurde bezüglich der Datensatz-Verweise für Taufpaten und Trauzeugen verbessert.

- Im Handbuch im Abschnitt FAQ - Häufig gestellte Fragen wurde ein Beitrag Wie übertrage ich den Stammbaumdrucker auf einen anderen Rechner? zugefügt.

- Diese Programm-Version 7.1.0.3 ist die letzte, die auch noch unter Windows XP läuft. Unter Windows XP kann diese Version 7.1.0.3 nicht mehr mit dem automatischen Programm-Update auf eine spätere Version aktualisiert werden. Die nächsten Programm-Versionen setzen mindestens Windows Vista voraus. Anwendern mit Windows XP wird dringend empfohlen, auf ein neueres Windows zu aktualisieren.

- Einige kleinere Korrekturen und Verbesserungen.

Version 7.1.0.2

- Der Teil-Baum-Assistent unterdrückte bei der Aufteilung von Nachkommenbäumen die Ausgabe von Nachkommen, wenn deren links angeordneter Elternteil ein Duplikat war, aber deren rechts angeordneter Elternteil kein Duplikat war. Der Fehler wurde beseitigt.

- Beim Aktualisieren der Ortslisten im Dialog Nachnamens-, Orts- und Religions-Listen bearbeiten wurde für standesamtliche Heiratsdaten nicht der Ort, sondern das Datum eingetragen. Dadurch erschienen in der Ortsliste Datumsangaben. Der Fehler wurde beseitigt.

- Unter seltenen Bedingungen enthielt die Werkzeugleiste einen Fehler: Das Anzeigefeld für den eingestellten Zoom der Baumansicht, z. B. [100%], stand nicht wie vorgesehen im Bereich der gelben Zoom-Funktionssymbole, sondern zwischen den Druck-Funktionssymbolen Druckvorschau und Drucken. Der Fehler wurde beseitigt.

- Die Zuordnung eines Neben-Farbschemas Bedingt (abhängig von Personendaten) in den Baumansichts-Optionen, Registerkarte Box-Farben, Unterregisterkarte Zuordnung der Neben-Farbschemata, wurde seit Version 7.1.0.0 in den Baumansichtsdateien *.sad unter Umständen falsch gespeichert. Der Fehler trat auf, wenn aus der Liste der Datenfelder (...die Angabe für [Datenfeld]) ein Datenfeld unterhalb von Verliehene Titel gewählt wurde. Der Fehler wirkte sich so aus, dass beim nächsten Laden der Baumansichtsdatei *.sad nicht das ursprünglich gewählte Datenfeld erkannt wurde, sondern das in der Liste darunter stehende Datenfeld. Der Fehler wurde beseitigt.

- Ein benutzerdefiniertes Baumansichts-Optionen-Profil, das man in den Programm-Optionen für die Auto-Baumansichten in Textverarbeitungs-Vorlagen festlegte, wurde zwar gespeichert, aber nicht wieder korrekt gelesen. Der Fehler wurde beseitigt.

- Im Dialog Personendaten bearbeiten, Registerkarte Partner und Kinder, konnte bei aktivierter moderater Geschlechtsprüfung (Dialog Personendaten, Registerkarte Integritätsprüfung) für eine Person die gleiche Person als Partner gewählt werden, ohne dass der Eingabefehler erkannt wurde. Dieser Eingabefehler wird jetzt von der Integritätsprüfung erkannt.

- Bei der Ausgabe von Partner-Eltern in Nachkommenbäumen erfolgte die Partner-Eltern-Abkürzung bisher nicht, wenn die zu vergleichenden Namen einmal groß und einmal klein geschrieben waren. Der Vergleich erfolgt jetzt ohne Berücksichtigung der Groß-/Kleinschreibung.

- Bei der Ausgabe von Partner-Eltern in Nachkommenbäumen wurden Nachnamen von Partner-Eltern stets abgekürzt, wenn sie dem Nachnamen des Partners glichen. Diese Abkürzung kann jetzt aktiviert oder deaktiviert werden: Baumansichts-Optionen, Registerkarte Box-Inhalt, Liste Ausgabe Personendaten, Abschnitt spezielle Format-Optionen, Kontrollfeld Nachnamen von Partner-Eltern in Nachkommenbäumen abkürzen, wenn = Partner-Nachname. Die Voreinstellung ist 'aktiviert'.

- Der Dialog Nachnamen-, Ort- und Religions-Listen bearbeiten kann jetzt in der Größe verändert werden, um auch lange Nachnamen und Ortsangaben vollständig zeigen zu können. Weiterhin wird wie üblich bei abgeschnittenen Texten ein Hinweisfenster mit dem kompletten Text gezeigt, wenn die Maus auf einen solchen Eintrag zeigt.

- Bei der Erzeugung von Teil-Bäumen mit dem Teil-Baum-Assistenten werden jetzt auf den Teil-Bäumen keine automatisch erzeugten Grafik-Titel und keine automatisch erzeugten Legenden mehr ausgegeben, auch wenn dies im zu Grunde liegenden Gesamt-Baum der Fall ist. Die automatisch erzeugte Beschriftung kann in vielen Fällen wegen Platzmangels im Bereich der Personen-Boxen nicht ausgegeben werden, was zu störenden häufigen Rückfragen führt. Besser ist es, im Gesamt-Baum manuell freie Text-Objekte für den Grafik-Titel und die Legende anzulegen, die dann auch in allen Teil-Bäumen erzeugt werden und dort manuell optimal platziert werden können.

- Im Hauptmenü wurde der Aufruf der Textverarbeitung aus dem Menü Extras herausgenommen und als eigenständiges Menü Textdokument neben das Menü Baumansicht gestellt. Damit sind beide Hauptaufgaben des Programms in der obersten Menü-Ebene vertreten. Das Menü Textdokument enthält Einträge zum normalen Öffnen der Textverarbeitung und zum Öffnen mit sofortiger Anzeige der Vorlagen-Fibel und einiger Vorlagen-Beispiele aus der Vorlagen-Fibel.

- In der Textverarbeitung kann in den Seiteneinstellungen mit einem Kontrollfeld bestimmt werden, dass auf Seiten mit gerader Seitennummer ungleiche Seitenränder links/rechts getauscht werden. Diese Einstellung war bisher nur beim direkten Drucken wirksam. Jetzt wirkt diese Einstellung auch beim PDF-Export. Außerdem ist diese Option jetzt aus technischen Gründen eingeschränkt: Sie ist nicht mit einer nicht weißen Hintergrund-Farbe oder einem Hintergrund-Bild vereinbar.

- Beim Gedcom-Import werden jetzt eigentlich unzulässige Kommas zwischen mehreren Vornamen im NAME-Tag entfernt. Diese Kommas störten die Stammbaumdrucker-interne Rufnamen-Kennzeichnung.

- Einige kleinere Korrekturen und Verbesserungen.

Version 7.1.0.1

- Im Handbuch, Abschnitt Die Dialoge, Baumansichts-Optionen, Registerkarte Box-Inhalt, Inhalt der Liste Ausgabe Personendaten, Abschnitt spezielle Format-Optionen, Vorname(n), fehlte das Kontrollfeld Einstellung auch für Partner-Eltern in Nachkommenbäumen. Im realen Dialog war dieses Kontrollfeld aber vorhanden. Der Fehler im Handbuch wurde beseitigt.

- Beim Export der Personendaten in eine Textdatei wurde im Datenfeld der Religion das Geburtsdatum exportiert. Der Fehler wurde beseitigt.

- Im Dialog Person auswählen fehlte in der aufklappbaren Auswahlliste für den Inhalt der letzten Spalte das Datenfeld Verliehene Orden, das in Version 7.1.0.0 eingeführt wurde. Der Fehler wurde beseitigt.

- Seit Version 7.0.2.0 befand sich versehentlich in der Werkzeugleiste des Editors für freie Text-Objekte eine Test-Schaltfläche mit der Beschriftung Button1. Diese Schaltfläche wurde beseitigt.

- Wenn in einem Teil-Baum zwei Personen mit gleichen Namen und ohne weitere Daten auftraten, wurde beim PDF-Export nur ein einziger Eintrag in den PDF-Lesezeichen gemacht. Auch ein exportiertes Personen-Verzeichnis enthielt für diese Personen nur einen einzigen Eintrag. Der Fehler wurde beseitigt.

- Der Teil-Baum-Assistent unterdrückte bei der Aufteilung von Nachkommenbäumen die Ausgabe von Nachkommen, wenn deren rechts angeordneter Elternteil ein Duplikat war, aber deren links angeordneter Elternteil kein Duplikat war. Solche Fälle können auftreten, wenn zum Beispiel zwei Nachkommen nacheinander dieselbe Person geheiratet haben. Der Fehler wurde beseitigt.

- In den aufklappbaren Auswahllisten für Zeichen-Formatvorlagen der Textverarbeitung (in der Format-Werkzeugleiste und im Dialog Formatvorlagen bearbeiten) fehlten unter seltenen Bedingungen die Texte. Der Fehler wurde beseitigt.

- In der integrierten Textverarbeitung wurden beim HTML-Export von Textdokumenten die horizontalen Linien nicht mit exportiert. Der Fehler wurde beseitigt.

- In der integrierten Textverarbeitung ist nun die vorlagenbasierte Erzeugung von Nachkommenlisten in der Struktur eines aktuell angezeigten Nachkommenbaums möglich. Die Zeilen der Nachkommen werden eingerückt; der Einzug wächst mit jeder Generation. Eine hierfür geeignete Vorlage besteht aus nur fünf einfachen Zeilen. In der neuen Vorlagen-Fibel wird im Abschnitt Einfache und strukturierte Personenlisten, Strukturierte Liste der Personen des aktuellen Nachkommenbaums, ein Vorlagen-Beispiel erläutert und zum Kopieren bereitgestellt.

- In den Gedcom-Optionen, Registerkarte Bürgerort-Codierung, wurde die Methode Benutzerdefiniertes Merkmal (beim Import auch mit untergeordnetem PLAC-Tag) aufgeteilt in zwei Methoden Benutzerdefiniertes Merkmal und Benutzerdefiniertes Merkmal mit untergeordnetem PLAC-Tag. Damit kann diese Methode nun auch beim Export verwendet werden.

- Einige kleinere Korrekturen und Verbesserungen.

Version 7.1.0.0

- Wichtige Neuheit: Das Programm steht nun auch in einer 64-Bit-Version zur Verfügung, die nur unter den 64-Bit-Versionen von Windows XP, Vista, 7 und 8 läuft. Die 64-Bit-Version ist etwas schneller und kann vom vorhandenen Arbeitsspeicher mehr nutzen als die 32-Bit-Version. Ein Wechsel von der 32-Bit-Version zur 64-Bit-Version kann nur durch Deinstallation der 32-Bit-Version und Neuinstallation der 64-Bit-Version erfolgen. Zur Neuinstallation der 64-Bit-Version stehen Downloads zur Verfügung. Zukünftige Updates der 64-Bit-Version werden wie gewohnt innerhalb des Programms erfolgen.

- Wichtige Neuheit: Das programminterne Update-Verfahren wurde so umgestellt, dass die automatische Suche und Meldungen über verfügbare Updates auch erfolgen, wenn das Programm nicht als Administrator ausgeführt wird. Erst zur tatsächlichen Aktualisierung muss das Programm als Administrator ausgeführt werden.

- Wichtige Neuheit: Änderung der Anwendungsdatenverzeichnisse: Dies ist für Sie nur von Interesse, wenn Sie das Programm auf dem System-Laufwerk (in der Regel C: ) installiert und von verschiedenen Benutzerkonten aus verwendet haben. Die neuen Anwendungsdatenverzeichnisse werden im Anhang des neuen Handbuchs im Abschnitt Programm-Verzeichnisse genannt.
Details: Bei Installation auf dem System-Laufwerk wurde in Programm-Versionen vor 7.1.0.0 für jedes Benutzerkonto ein eigenes Anwendungsdatenverzeichnis verwendet. Ab Version 7.1.0.0 wird für alle Benutzerkonten ein einheitliches Anwendungsdatenverzeichnis verwendet, sodass die grundlegenden Programm-Einstellungen für alle Benutzer gleich sind. Dies betrifft die Initialisierungsdatei Stammbaumdrucker.ini (Programm-Optionen, Gedcom-Optionen und gegebenenfalls die benutzerdefinierte Voreinstellung der Baumansichts-Optionen), Baumansichts-Optionen-Profile *.opt, Gedcom-Optionen-Profile *.gco, eine angepasste Ausgabesprachendatei Stammbaumdrucker.spr, eine angepasste Kontextsortierungdatei Stammbaumdrucker.ksd, die Konfigurationsdatei der Rechtschreibprüfung SBDspell.cfg sowie Rechtschreibprüfungs-Benutzerwörterbücher *.adu.
Hinweis: Das Anwendungsdatenverzeichnis dient der Speicherung von versteckten Dateien der Anwendung = Stammbaumdrucker, um deren Existenz und Name sich der Anwender = Benutzer normalerweise nicht kümmern muss. Dieses Verzeichnis ist im Windows Explorer nur sichtbar, wenn die versteckten Verzeichnisse nicht ausgeblendet werden. Das Anwendungsdatenverzeichnis darf nicht mit dem Verzeichnis Eigene Dateien oder Eigene Dokumente verwechselt werden, in dem der Anwender = Benutzer seine eigenen persönlichen Dateien wie zum Beispiel Familiendateien und Bilddateien ablegt.

- Wenn die Textverarbeitung mit einem neuen, leeren Dokument geöffnet wurde, wurde diese leere Seite nicht in den Seitenminiaturen angezeigt. Der Fehler wurde beseitigt.

- In Baumansichten Nachkommen der Großeltern und Nachkommen der Urgroßeltern konnte unter sehr seltenen Bedingungen ein rechter Mausklick auf die Box eines rechts angeordneten Partners eines Nachkommen einen Fehler bei Bereichsprüfung auslösen, anstatt das umgebungsabhängige Menü zu öffnen. Der Fehler wurde beseitigt.

- Im Teil-Baum-Assistenten fehlte nur auf der ersten Tafel oben links die Schaltfläche zum Minimieren und Maximieren des Fensters. Der Fehler wurde beseitigt.

- Im aufklappbaren Auswahlmenü von Personen-Boxen, das mit der rechten Maustaste geöffnet wird, wurden zwei Funktionen umgebannt, um sie deutlicher zu kennzeichnen: Farbschema ersetzen für... -> Ersatz-Farbschema verwenden für... sowie Farbschema zurücksetzen für... -> Ersatz-Farbschema zurücksetzen für....

- In den Personendaten, Registerkarte Merkmale und Ereignisse, gibt es das neue Datenfeld Verliehene Orden. Dieses ist zum Beispiel für das Eiserne Kreuz oder für das Bundesverdienstkreuz vorgesehen. Die Ausgabe kann in den Baumansichts-Optionen, Registerkarte Box-Inhalt, Liste Ausgabe Personendaten, aktiviert werden. Das Datenfeld wird beim Gedcom-Import und -Export berücksichtigt.

- In den Personendaten, Registerkarte Merkmale und Ereignisse, wurde das Datenfeld Titel in Verliehene Titel umbenannt. Damit soll deutlich gemacht werden, dass es nicht für adlige Titel vorgesehen ist, die in das Datenfeld für die Nachnamen gehören.

- In den Baumansichts-Optionen, Registerkarte Box-Inhalt, Liste Ausgabe Personendaten, Abschnitt spezielle Format-Optionen, kann die Ausgabe von verliehenen Titeln, verliehenen Orden und Ordenzugehörigkeiten zusammen in einer Zeile eingestellt werden: Titel, Orden und Ordenszugehörigkeit [x] zusammen in einer Zeile. Automatische Umbrüche wegen mangelnder Breite der Personen-Boxen werden hierdurch nicht verhindert.

- In den Baumansichts-Optionen, Registerkarte Box-Inhalt, Bereich Ausgabe Nachkommennummern, Auswahlliste System, können jetzt Nachkommennummern wie im Genealogischen Handbuch des Adels ausgewählt werden: Gotha 1: Eine Ebene und Gotha 2: Alle Ebenen. Diese Systeme können Nachkommennummern für höchstens neun Nachkommen-Generationen erzeugen, also bis (aa), (bb), (cc), usw..

- Bei der Ausgabe von Partner-Eltern in Personen-Boxen in Nachkommenbäumen wird ein Eltern-Nachname abgekürzt, wenn er dem Partner-Nachnamen gleicht; damit wird Platz gespart. Außerdem kann die Ausgabe der Vornamen der Partner-Eltern an die der Box-Person angepasst werden: Dafür gibt es in den speziellen Format-Optionen, Abschnitt Vorname(n), das neue Kontrollfeld Einstellungen auch für Partner-Eltern in Nachkommenbäumen. Wenn dieses Kontrollfeld nicht markiert ist, wird nur der Rufname der Partner-Eltern ohne Unterstreichung ausgegeben.

- Bei der Ausgabe der Besitzung in Personen-Boxen wird ein auf im gespeicherten Besitzungs-Text durch das auf aus der Ausgabesprachendatei ersetzt. Außerdem wird das auf aus der Ausgabesprachendatei vorangesetellt, wenn der gespeicherte Besitzungs-Text nicht mit auf beginnt. Damit sind korrekte Ausgaben auch in anderen Sprachen möglich.

- Bei der Ausgabe der Besitzung auf Karteikarten wird ein auf am Anfang des gespeicherten Besitzungs-Textes entfernt. Außerdem wird ein auf weiter hinten im Besitzungs-Text durch das auf aus der Ausgabesprachendatei ersetzt. Damit sind korrekte Ausgaben auch in anderen Sprachen möglich.

- Bei der Ausgabe der Besitzung mit Hilfe des Daten-Feldes <%Besitzung%> in einer Vorlage der Textverarbeitung wird ein auf am Anfang des gespeicherten Besitzungs-Textes entfernt.

- Beim Export der Datensätze als Kartei in eine PDF-Datei werden jetzt nicht nur fehlende Dokumentdateien, sondern auch fehlende Fotodateien gemeldet.

- Einige kleinere Korrekturen und Verbesserungen.
Schon mal in das Handbuch geschaut? :wink: Oder in die Hilfe? :?:

Zurück zu „Änderungs-Logbuch und Liste bekannter Fehler“

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast